Cisco маршрутизаторы,  зарекомендовали себя с лучшей стороны давно. И как раз мне в руки попал маршрутизатор Cisco 881. Он уже не много устарел, но свои функции выполняет на ура.

В этой статье мы поговорим о настройки маршрутизатора Cisco 881 для выхода в интернет. Так же мы выполним минимальные рекомендации по защите устройства, но об этом мы поговорим позже, а пока переходим к практической части.

 

Все настройки выполняются в привилегированном режиме. 

Шаг первый.

Если не сменили имя устройства, то меняем его.

Router# conf t 
Router(config)#hostname R1
R1(config)#

Шаг второй.

Настройка интерфейса WAN

Исходные данные WAN. Пример

IP адрес постоянный(белый), но получим его по DHCP (195.38.44.2) У вашего провайдера адрес может быть и статичный.
Маска: 255.255.255.252 /30
Шлюз по умолчанию: 195.38.44.1

Посмотреть шлюз можно командой show ip route

R1(config)#  int fa 4
R1(config-if)# ip address dhcp
R1(config-if)# description WAN Ethernet //не обязательный параметр
R1(config-if)# no shutdown

Сохраним настройки нашего маршрутизатора cisco.  Если это не сделать, то после перезагрузки, все настройки пропадут.

R1(config-if)# do wr mem

Первый вариант

R1(config-if)# do copy running-config startup-config

Второй вариант

R1(config-if)# end
R1# wr mem

Третий вариант.

R1# copy running-config startup-config

Шаг третий.

Настройка внутренних интерфейсов

Исходные данные LAN

192.168.60.0 /24 
Пул адресов dhcp сервера 192.168.60.20 - 192.168.60.240 //Если у Вас нет отдельного dhcp сервера.

Теперь мы можем и настроить Vlan 1 или создать например Vlan 2 и уже ему прописать наш IP. Но нужно учитывать, если у вас на коммутаторах есть другие Vlan. То на маршрутизаторе необходимо настраивать sub интерфейсы (vlan 10 — gi0/0.10). Это материал отдельной статьи. В данной статье настроим Vlan1

R1(config)#  int vlan 1
R1(config-if)# ip  address 192.168.60.1 255.255.255.0
R1(config-if)# no shutdown

Так как мы настривали Vlan 1, который установлен по умолчанию, и все порты маршрутизатора настроены именно на Vlan 1. Если Вы создали Vlan 2 и настроили его, то указываем команду

switchport access vlan 2

Теперь настроим наш DHCP server

R1(config)# ip dhcp pool Pool1
R1(dhcp-config)# network 192.168.60.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.60.1
R1(dhcp-config)#
dns-server 192.168.60.1
R1(dhcp-config)# do wr mem
R1(dhcp-config)# exit

Кроме того исключим адреса из раздачи DHCP

R1(config)# ip dhcp excluded-address 192.168.60.2 192.168.60.19 //исключаем адреса
R1(config)# ip dhcp excluded-address 192.168.60.241 192.168.60.254 //исключаем адреса

Так же можно поднять DHCP и DNS server отдельно. Примеры можно посмотреть здесь. Ubuntu DNS , Ubuntu DHCP или FreeBSD DNS и FreeBSD DHCP. Останется только  ввести команду. В качестве примера ip нашего DNS и DHCP будет 192.168.60.5.

R1(config)# default-router 192.168.60.5
R1(config)# dns-server 192.168.60.5
R1(config)# do wr mem
/*Команда вводится отдельно. На Cisco в таком случае поднимать DHCP не нужно!*/

Шаг четвертый.

Настроим NAT. Основные настройки мы сделали. Остается толь разрешить внутренний сети выход в интернет.

Создаем разрешающее правило ACL

R1(config)# ip access-list standard ACL_NAT
R1(config)# permit 192.168.60.0 0.0.0.255

Указываем внутренний интерфейс NAT

R1(config)# int Vlan 1
R1(config-if)# ip nat inside
R1(config-if)# do wr mem //сохраняем настройки

Теперь укажем внешний интерфейс NAT

R1(config)# int fa 4
R1(config-if)# ip nat outside
R1(config-if)# do wr mem

А сейчас создадим правило трансляции NAT

R1(config)# ip nat inside source list ACL_NAT interface fa4
R1(config)# do wr mem

Мы произвели все необходимые настройки, чтобы мы могли выйти в интернет с любого ip адреса сети 192.168.60.0/24. Вводите команды внимательно, если что-то пропустили, ничего страшного, маршрутизатор Вам подскажет на Ваши ошибки. Всем приятной работы. Надеюсь, моя статья была для Вас полезной.

Добавить комментарий

Ваш адрес email не будет опубликован.